Back to overview
Resolved
Elevated latency on Spott platform & API
Sep 15, 2026 at 8:22am UTC
Affected services
app.gospott.com
Resolved
Sep 15, 2026 at 9:16am UTC
We have found the possible root cause issue and are deploying a mitigation.
Affected services
Created
Sep 15, 2026 at 8:22am UTC
Users are reporting elevated latency and slow load times, both on platform and API. We are actively investigating the issue.
Affected services